violet/PKGBUILD
2021-08-30 14:39:38 +02:00

40 lines
773 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Your Name <youremail@domain.com>
pkgname=violet
pkgver=1.0
pkgrel=1
epoch=
pkgdesc=""
arch=('x86_64')
url="https://git.hippoz.xyz/rice/violet"
license=('GPL')
groups=()
depends=()
makedepends=("rust")
checkdepends=()
optdepends=()
provides=()
conflicts=()
replaces=()
backup=()
options=()
install=
changelog=
source=("git+https://git.hippoz.xyz/rice/violet")
noextract=()
md5sums=('SKIP')
validpgpkeys=()
build() {
cd "$pkgname"
make
}
package() {
cd "$pkgname"
make DESTDIR="$pkgdir/" install
}